We’ve addressed the recent issues impacting MyProcare, and services are now stabilizing.
The disruption occurred between Sept 24 at 11:00 AM MT and Sept 25 at 3:10 PM MT. Our team will continue monitoring closely to ensure full resolution.
There is no action required on your part - ledger discrepancies will be corrected systematically behind the scenes, and all impacted schools will receive follow-up by Monday, Sept 29.
Additionally, some Procare Desktop with Engage customers may have experienced syncing disruptions. These services are also recovering, though it may take additional time for all syncs to complete.
Posted Sep 26, 2025 - 12:36 MDT
Monitoring
We’ve addressed the recent issues impacting MyProcare, and services are now stabilizing. Our team will continue monitoring closely to ensure full resolution.
Additionally, some Procare Desktop with Engage customers may have experienced syncing disruptions. These services are also recovering, though it may take additional time for all syncs to complete.
Posted Sep 26, 2025 - 11:17 MDT
Update
We are continuing to investigate issues with MyProcare. As part of ongoing relief efforts, some Procare Desktop with Engage customers may experience disruptions when syncing with Engagement functionality. Our team is actively monitoring the situation and will provide updates as soon as more information becomes available.
Posted Sep 26, 2025 - 10:03 MDT
Investigating
Our team is aware of degraded performance in MyProcare. Some users may experience login issues, intermittent slowness, or error messages while navigating. We are actively investigating and will provide updates as more information becomes available.
Posted Sep 26, 2025 - 08:30 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal).