Point of Sale (POS) — Service Disruption

Incident Report for Procare Solutions Service Status

Resolved

This issue has been resolved. Our engineering team identified the root cause as a monitoring configuration change that was blocking payment screens from loading in SchoolCareWorks. A fix was applied and payment screens are now loading and processing normally.

We apologize for the disruption and thank you for your patience.
Posted Jul 27, 2026 - 08:27 MDT

Investigating

We are currently aware of an issue affecting Point of Sale (POS) functionality in SchoolCare Works for some users. Payment screens may fail to load, which can prevent payment transactions from being completed.

Our engineering team has been engaged and is actively working to resolve this as quickly as possible. We appreciate your patience and will provide updates here as our investigation progresses.
Posted Jul 27, 2026 - 07:52 MDT
This incident affected: SchoolCare Works/DayCare Works (API, SchoolCareWorks Main Site, DayCareWorks Main Site).