The email delivery issue has been resolved, and service has been fully restored. All queued emails are now being delivered. Thank you for your patience during this disruption.
Posted Dec 30, 2025 - 20:43 MST
Identified
We continue to actively work with our email service provider to resolve the current disruption. Emails remain queued and will be delivered once service is restored. Our team is making progress, and we anticipate a resolution soon. Thank you for your patience.
Posted Dec 30, 2025 - 15:04 MST
Investigating
We are currently experiencing an issue with our email delivery service that may impact all email types from the Procare Online platform. Our team is working with our email provider to resolve this quickly. In the meantime, emails are being queued and will be sent once service is restored. We expect this to be resolved shortly and will provide updates as we have them. We apologize for any inconvenience.
Posted Dec 30, 2025 - 10:56 MST
This incident affected: Procare Online/Family Engagement (Schools Login, API).