Payment Processing Delays

Incident Report for Procare Solutions Service Status

Resolved

The payment processing delay has been fully resolved. All affected transactions have been successfully processed, and funding is complete. Payment processing is now operating normally. Thank you for your patience.
Posted Aug 13, 2025 - 10:42 MDT

Identified

We are continuing to investigate the issue affecting some payment transactions. Our team has identified additional payments from July 31 through August 7 and are processing these today. All funds remain secure and payments will complete processing with funding expected tomorrow. We appreciate your patience and will provide updates as more information becomes available.
Posted Aug 12, 2025 - 09:12 MDT

Investigating

We are aware of an issue affecting some payment transactions and are actively investigating. All funds remain secure. We will provide an update as soon as more information is available.
Posted Aug 11, 2025 - 14:49 MDT
This incident affected: Payment Processing (API).