The payment processing issue affecting one-time payments in our mobile app has been resolved. All payments are now processing as expected. Families who experienced an authentication error can now retry their payment.
We apologize for any inconvenience this may have caused and thank you for your patience. If you continue to experience issues, please contact Procare Customer Support by utilizing the chat on the bottom right-hand corner of Procare Online.
Posted Mar 31, 2026 - 10:00 MDT
Update
We are continuing to investigate reports of authentication errors when processing payments in our mobile application. We can confirm this issue is isolated to one-time payments only. Families on recurring plans are not affected and payments will continue to process as normal.
In the meantime, all payments on the web are processing as expected. We recommend using the web platform to process one-time payments until this issue is resolved: https://schools.procareconnect.com/login
We appreciate your patience and will share further updates as they become available.
Posted Mar 31, 2026 - 08:25 MDT
Investigating
We are currently investigating reports of customers receiving authentication errors when attempting to process payments within our mobile application. Our team is actively working to identify the cause and scope of this issue.
In the meantime, payments on the web are processing as expected. We recommend using the web platform to process payments until this issue is resolved: https://schools.procareconnect.com/login
We will provide updates as more information becomes available.
Posted Mar 31, 2026 - 07:39 MDT
This incident affected: Payment Processing (API, PayNow).