Desktop Application Login Issues

Incident Report for Procare Solutions Service Status

Resolved

The login issues affecting some Desktop application users have been resolved. The service is now operating normally. Thank you for your patience.
Posted Nov 14, 2025 - 16:57 MST

Monitoring

The connection issues affecting some Desktop application users have been resolved. The issue was identified as an upstream provider problem that has now been corrected. Users should now be able to log in to the desktop application normally. We will continue to monitor the service to ensure stability. If you continue to experience any issues, please contact our support team. Thank you for your patience during this interruption.
Posted Nov 14, 2025 - 12:59 MST

Investigating

We are currently investigating reports from some Desktop application users experiencing connection errors when attempting to log in. Users may see an error message indicating "A connection was successfully established with the server, but then an error occurred during the login process." Our technical team is actively working to identify and resolve the issue. We will provide an update as soon as more information becomes available.
Posted Nov 14, 2025 - 10:36 MST
This incident affected: Procare Desktop (Cloud Database Cluster - Primary).