Procare Desktop Tuition Express Performance Issues

Incident Report for Procare Solutions Service Status

Resolved

The Tuition Express screen loading delays have been fully resolved. All functionality has been restored, and the processing screen is operating normally. Thank you for your patience.
Posted Aug 15, 2025 - 18:34 MDT

Monitoring

The Tuition Express screen loading delays have been resolved. Users who experienced slow loading times or missing payment profiles should close and reopen Procare to apply the update. The processing screen is now loading normally. Thank you for your patience.
Posted Aug 15, 2025 - 10:00 MDT

Investigating

We are currently investigating issues related to the recent changes in upgrading Procare Desktop customer payment profiles in Tuition Express. The upgrade process improves security but may take longer than expected to complete. Please leave the screen open until the upgrade finishes. We have identified that some payment profiles do not appear after the upgrade. Our engineering team is actively working to resolve this issue, and updates will be provided as more information becomes available.
Posted Aug 15, 2025 - 08:17 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal, Cloud Database Cluster - Primary, Web Apps).