Procare Online Android App Issues

Incident Report for Procare Solutions Service Status

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 06:14 MDT

Update

Resolved – Updated Required
A fix has been released for the Android login/crash issue.
Updating the Procare Online app to version 6.4.2 in the Google Play Store is required to ensure a successful login and prevent further issues.
We appreciate your patience as we worked to resolve this.
Posted Oct 28, 2025 - 06:14 MDT

Update

A new version of the Procare app has been submitted to Google Play and is currently awaiting approval. The review process can take up to one business day.

Until the update is approved and released, some Android users may continue experiencing login issues or app crashes through Tuesday, October 28th. We’ll share another update once approval is confirmed and outline next steps at that time.
Posted Oct 27, 2025 - 14:20 MDT

Identified

Our team is actively assessing potential solutions and working to resolve the issue. We’ll continue to share updates as we make progress.
Posted Oct 27, 2025 - 11:43 MDT

Investigating

We’re aware of an issue impacting some Android users using the Procare Online app. Affected users may experience login difficulties or app crashes. This issue can impact both staff and parents.

Our team is actively investigating and working on a resolution.

Depending on your school or center’s setup, the Procare Online web version may serve as a temporary workaround: https://schools.procareconnect.com/login

We’ll share an update as soon as more information is available.
Posted Oct 27, 2025 - 08:22 MDT
This incident affected: Procare Online/Family Engagement (Schools Login).