The intermittent slowness and errors affecting Procare Online have been fully resolved. Our engineering team has identified and addressed the root cause, and all systems are operating normally. We apologize for any inconvenience and thank you for your patience. Please contact Procare Customer Support if you have any questions.
Posted Jan 20, 2026 - 11:32 MST
Update
Our engineering team has mitigated the intermittent slowness and errors in Procare Online. Root cause investigation is ongoing, and system performance should be returning to normal. Please contact Procare Customer Support if you continue to experience issues.
Posted Jan 20, 2026 - 10:07 MST
Investigating
We have received reports of users experiencing slowness or intermittent error messages on Procare Online (web). Our Development team is actively investigating and will provide updates as more information becomes available.
Posted Jan 20, 2026 - 09:23 MST
This incident affected: Procare Online/Family Engagement (Schools Login, API).